Witnessing slow down in e-mail delivery
Incident Report for Cargobase
Resolved
This incident has been resolved.
Posted Dec 14, 2018 - 10:31 UTC
Monitoring
This issue has been identified and solved. We will continue to monitor for the time being.
Posted Dec 14, 2018 - 06:14 UTC
Investigating
Some users are reporting a delay in e-mail delivery. We are aware of the issue and are currently investigating.
Posted Dec 14, 2018 - 04:14 UTC
This incident affected: Cargobase e-mail service.