Mail Delivery Issue Towards Microsoft 365 Accounts
Incident Report for Cargobase
Resolved
The issue is now considered closed.
Posted Jul 02, 2020 - 09:12 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 02, 2020 - 08:03 UTC
Monitoring
The problem should now have been resolved - if your experience issues in receiving message, please reach out to support@cargobase.com
Posted Jul 02, 2020 - 08:02 UTC
Identified
An issue has been identified with e-mail delivery from Cargobase to certain mailservers that rely on Microsoft.
Some Cargobase mails are rejected. We are working to remove this blockage, but at this moment we do not have a specified end time.

Please ensure you refresh the platform frequently if you are awaiting certain updates.
Posted Jul 02, 2020 - 06:42 UTC
This incident affected: Cargobase e-mail service.