Cargobase Platform Slowness
Incident Report for Cargobase
Postmortem

Platform System Slowness
Root Cause Analysis
Date & Time
Issue Found: 06 Sep 2024 1630 SGT
Issue Resolved: 06 Sep 2024 1715 SGT

Issue Details
On 6 Sep 2024, our software platform experienced slowness, impacting the user experience. The root cause was identified as a database query taking longer than expected to complete.

Root Cause
The slowness was traced back to an inefficient database query that took longer than expected to complete. This caused delays in the system’s ability to process user requests in a timely manner.

Corrective Action
·      The problematic database query was reviewed and optimized to reduce execution time.
·      Post-optimization, the system’s performance returned to expected levels.

Preventive Action
Monitoring tools have been put in place to proactively identify and address any future performance issues related to database queries.

Posted Sep 26, 2024 - 07:28 UTC

Resolved
Cargobase Platform experienced slowness on 6th September 2024 4:30 pm SGT. The issue is resolved at 5:15 pm SGT. We are investigating the root cause.
Posted Sep 06, 2024 - 08:30 UTC