Internet Explorer 11 - Compatibility issue
Incident Report for Cargobase
Resolved
The incident has been resolved.
Posted May 17, 2019 - 06:07 UTC
Investigating
It seems that some users are experiencing compatibility issues when using internet explorer.
We are investigating at the moment.
In the meantime, we recommend using either Google Chrome or Apple Safari.
Posted May 17, 2019 - 03:00 UTC
This incident affected: Cargobase platform.